How to get the sum result of custom fields with Named Groups

The custom fields are set in Empower 3 as follows.

Formula:
CPA_HR: 20*Area/(Retention Time*60)
Total_CPA: Sum(CPA_HR)
CPA_Percent: 100*CPA/Total_CPA

The named group "LMWs" includes LC, F1, F2, F3 and HHL peaks.

May I know how to get the CPA_Percent of "LMWs"?

I can get the value by total impurities but I would like to know how to get the impurities in groups.

Thank you. ^^


Comments

  • Ensure that both the sample type and peak type are set to all. Limit the search order to result set only. 

    Most importantly, tick the box so that the custom field performing the summation will run for a "missing peak". 

    If you have already done that, then what does the CPA custom filed look like? You have given us CPA_HR, Total_CPA, and CPA_Parent. However, CPA_Parent is:100*CPA/Total_CPA, so what is the CPA custom field?
  • Sorry for the wrong information. 
    Please find the settings below.

    The settings work since the CPA_HR and CPA_Percent shown by Timed Group but not Named Group.
    It's a pity that the result of Timed Group is wrong and it's not suitable for the quantitation that the impurity(HHL) and main component (Monomer) are not separated.
    And it is rational that the results should be quantitated by Named Group .
     
    I am appreciated for your answer.  ^^


    Named Group (LMWs)


    Timed Group (LMWs-Timed Groups)



    1. CPA_HR


    2. Total_CPA_HR



    3. CPA_Percent



  • I created the 3 CFs as you set out, but the difference is I changed the name of the percent custom field to X_Total because custom fields that depend on each other should be named in alphabetical order so they calculate in the correct order so CPA_HR begins with C, Total_CPAHR begins with T and X_Total begins with X.


    It worked out fine for me when I added a few components to a Named Group but I selected in the processing method Named Groups tab, under the option "Source of Calibration X Value" - Sum Peaks, Curve or Sum Peaks for Quantitation". Maybe changing it to that would help.

  • The settings were changed but did't work. 
    Did I miss something?

    Thank you for the reply. ^_^





  • Do you have the custom field Peak Type set to "All" in your custom field editor? And what do you have your Sample Type set to? You could be excluding unknowns or standards etc. Sample and Peak Type should be All for all the custom fields.
  • I had to use result type fields and tick "missing peak". 
  • I found that the LMWs of named group is shown in the multiple summary report but not in the data review.

    The LMWs of time group can be shown in data review but not for named group.
    It might be because the time group is with one retention time and could be calculated by the formula of CFs.
    Named group is with 5 peaks and the retention time cannot be defined, thus the sum of %LMW cannot be shown in the data review by CFs.
     
    Maybe I need to try the other formula of CFs to test if the LMWs could be shown in the data review directly.

    Thank you all.  ^^
  • In the peak table where you want the peak groups to appear, you need to make sure you have not excluded peak groups. I believe the peak groups are excluded by default. 

    Double click the table in the report editor ... click the Peaks tab ... ensure Group Peaks is ticked. 
Sign In or Register to comment.