Peak Lambda Max

I am trying to automate a PDA peak lambda maximum for a group of users that I support.

The analysis collects data from 210-400 nm and compares PDA lambda max in standards to samples as a means of positive ID. The PDA Max for the API is about 299 nm. However, there is other, higher absorbance at 210 nm.

Empower looks at the data in an unintelligent manner. If I create a custom field to identify Peak Lambda Max. I am returned a result of 210 every single time, as that is a true maximum in the entire plot.

So, I tried to get clever:

SAME.%.SAME.MAX(RANGE(Peak Lambda Max.,260,400))

But the above returns 0.0 every single time. If I had to guess, I am breaking Peak Lambda Max. by asking it to look over a range, 260-400 nm, which it's not allowed to do (as Max implies a single number). Furthermore, I'm restricting the Max from the true Max.

It seems like what I want shouldn't be hard to accomplish, but it is...

Has anyone every [successfully] tried to do anything similar?

Answers

  • I have no experience with this but can suggest that you change your instrument method to only look from 260nm to 400nm... That should work and leave you with smaller data files. Crude, but effective.
  • Agreed.

    Unfortunately, in this case, the method states to scan 210-400 nm.

    That is certainly the easiest approach, but is one that we can't currently take. I do plan to make a formal recommendation  to narrow the wavelength scan range regardless of if I can automate this or not...

  • Extract a channel with limited range and execute the max on that? That might be doable (but it might not - I;m not great w/ PDA).
  • edited August 23
    Could you split up the formula a bit? So one Peak, Bool CF called "Returned_Lambda" (or whatever)- Use as Field. Presuming your value is very close to 200nm all the time: GTE(Peak Lambda Max, 190)*(LTE(Peak Lambda Max,210)) For the translations 0 = "Outside Acceptable Range" and 1 = Peak Lambda Max (fc). 

    Then another peak, CF:

    SAME.%.SAME.MAX(Returned_Lambda). If its just one peak you are looking at then consider CCalRef1 in the "Returned_Lambda" field. This might be wise because Empower may have difficulty returning a MAX on both alphabetical and numerical values ie between the multiple values of "Outside Range" and values like 199, 197, 209nm etc.  Ive never tried to ask Empower to return a MIN or MAX etc on a Use as Field before but I cant imagine why it wouldn't do it. The only other thing I anticipate is you cant adjust the precision of Returned_Lambda or add up values in a peak report table so set your precision to whatever you want it when creating this Bool CF. 

    If you have multiple peaks you want to consider for the MAX, then alter the first Bool CF to Use As Position, translation for 0 being Outside Acceptable Range and 1 Being Within Acceptable Range. Then your second CF becomes:

    SAME.%.SAME.MAX((Peak Lamda Max*(EQ(Returned_Lambda,1)))


  • Hello - change the start wavelength in the processing method to something higher such as 220 so that it picks out the true lambda max.
  • edited August 23
    Second suggestion - after you change the start wavelength then change your custom field to something similar to this (put your label and injection in) S1.1..MAX(Peak Lambda Max.).  This works.
  • Do as user Neil suggests!  It's exactly what I do for some of our methods and it has worked for years.  It has no impact on your raw data or actual spectrum, but it allows you to report the maxima for wavelength range that actually matters to your method.
  • @ Neil - where do you set start wavelength in a PDA PM? Is it the purity tab? I thought that option was only to test the range for peak purity, surely Empower would always link to the instrument method range?


    Also, trying to force a MAX from Use as Field doesn't work I tried it. Probably what they mean when they say further CFs using the use as field are not typical..

    But I did get it to work for use as position 0 and 1 then an intersample summary cf as my earlier post.

  • Hi, yes it is on the purity tab under spectral contrast parameters.  The wavelength range is used for several things, peak purity amongst them.  If you leave the wavelength range at the defaults then Empower uses the wavelength range you set in the instrument method.  Otherwise you can set it to your liking and it will use that range for processing.
  • The spectral contrast parameters do not appear to have any impact upon wavelength range scanned, or at least not in a vanilla install of Empower, which is what the client is using. I have tried to tighten up these parameters as suggested, but it does not have an impact on the window used to generate the lambda max or its value.
  • I'm a little confused as to your root problem...the peak lambda max or the formula?

    For the peak max:
    It's all in the PM, not the IM, so it won't have any impact on what is actually collected for data.  I've attached some screenshots (E3 FR2/SR2)...using the built-in Peak Lambda Max field, not a custom field.  I then go further and use a custom field to subtract a sample's result from the applicable standard to demonstrate it matches.

    Doing this won't change raw data, or any visual results for that matter, and will just change the value reported for the Peak Lambda Max.  In your custom field, RANGE returns a true or false as a boolean test.  That's why it would only ever return 0 (false)...and then you took the max of that which is still 0.  Is there really a need for a custom field if you address the reported lambda max as above and the attachment?
  • Thanks Neil, great to know. 

    The custom field can work too though, if you split it up into a peak bool then peak real summary as my above post. This will work if you need the stored value of Lambda Max to be used in a further calculation. 
Sign In or Register to comment.