Standard curve calculation

I'm trying to calculate the theoretical area of my standard curve samples based on the curve I've generated and I can't get it to work.

My calculation is "Amount*B+A". When the data is processed only the last injection processed matches with the value I would expect to see. In addition, each point on the curve has triplicate injections and the theoretical area is different for each one, when it should be the same. 

Can anyone help me pinpoint what I'm doing wrong? Thanks!

Answers

  • Since you say only the last injection matches...Do you have a "Summarize Custom Fields" line at the end of the sample set?  If not, then that is likely the issue and a simple fix.
  • Thank you for the response, I wish it were that easy, but I do have a summarize custom fields line at the end.

    I am getting values for each injection, and most are less than 1% off what they should be. It seems like it might be building the curve as it does the calculation and therefore the A and B values are changing?
  • can you share a screen shot of sample set 
  • A small thing but try specifying your formula in brackets ie (Amount*B)+A. Ive had issues before where Empower calculates the wrong order in the formula. 
  • I'm able to re-create your issue and it would seem your conclusion about the slope/intercept values changing is the source of the issue.  When in review, you can cycle back through and re-calibrate and it fixes all the mis-alignment due to the way it updates the slope/intercept.  It's a bit odd considering that the slope/intercept are automatically updated throughout all the affected injections in the calibration so all match, so it's as if Empower doesn't recognize that the A/B values have been updated since the initial calculation of the theoretical area and using the summarize custom fields doesn't resolve this.  I tried a few things to resolve it (creating a custom field version of A and B and using those, changing around when/where in the sample set the summarize custom fields line was since my test sample set had multiple linearity curves to play with).

    One thing I tried worked, but it is not ideal.  Basically, stick a quantitate line into the sample set and re-process those injections.  Of course, you end up with double the results for your standards which is certainly not ideal.  I use stock wts with purity and dilution factors vs concentrations, so I did also have to change the formula to use the Value field, purity, dilution vs just the Amount field.

    I wonder if this would qualify for a "bug" issue since A and B aren't updated during processing such that custom fields are properly updated.
  • Its hard to describe this briefly, but i will try.

    Label the standard injections individually (ie: S1, S2, S3). Select your target label for A and B as the last standard injection. This should calculate your equation using the correct A and B values that have been determined from the last std injection.

    Example

    S1 First Std
    S2 Second Std
    S3 Last Std

    Equation targeting the last standard:

    Amount*S3..(B)+S3..(A)
  • @Bridget :It seems like it might be building the curve as it does the calculation and therefore the A and B values are changing?
     
    This is exactly what is happening, Bridget.

    To clarify my suggestion as it relates to your injection scheme, triplicate injections would require a specified injection from the standards: the final injection used to generate the curve....therefore,

    Equation targeting the last standard, injection 3: 

    Amount*S3.3.(B)+S3.3.(A)
  • @medicnman, thanks for the suggestion. When I try that equation it only calculates a value for my final injection, I get 0 for all the previous injections. I tried breaking it apart as well and having separate custom fields for the final slope/intercept, but that gave the same 0 results for the early injections.

    @MJS, thank you for trying out a bunch of stuff. I couldn't get it to work when I re-processed it with a quantitate line, so I think I might be doing it in the wrong order. Either way, not ideal, it definitely seems like a bug to me.
  • If you want to try, sometimes this will force an intersample to happen for previous sample lines.

    where standards are 
    S1
    S2
    S3
    Sn

    S%..((S%..(Amount)*Sn.3.(A))+Sn.3.(B))

    or 

    ..((..(Amount)*Sn.3.(A))+Sn.3.(B))


Sign In or Register to comment.