Out of memory

In our EMPOWER 1 the system audit trail is very big. When the filter is set to 'default' the configuration manager runs out of memory (see OutOfMem_01.gif). The (virtual memory of the machine seems to be enough (see OutOfMem_02.gif). We can change the filter but this cannot be saved. Then the configuration manager hangs and can only be closed by killing the cmgr.exe process (see OutOfMem_03.gif). When we try to edit the filter Empower says that only one instance of the editor (what editor) can be opened (see OutOfMem_04.gif).We tried to set another filter but this setting cannot be saved as default
The 'other setting' is killed by closing the configuration manager (killing the process)

What can we do to avoid this problem?Is there a possibility to get the 'default' overwritten?

Comments

  • Hello,

    The behavior you describe was resolved with the release of Empower 2.

    In Empower 2 when viewing project data in the Project window or information in Configuration Manager, you can set the maximum rows of data to be displayed in a table at one time.   In the Max Rows area, set the number of rows that you want to appear, and then click Update, or one of the paging buttons. Use the paging buttons to view subsequent pages of data containing the table rows above your specified maximum number of rows.

    If you are working from a client workstation you may want to try from a machine that has more physical memory.  Increasing the virtual memory will not help, as you have mentioned.

    In the Empower 1154 you may want to consider saving the Trail records by selecting the System Audit Trail view from Configuration Manager and then Select File > System Audit Trail > Archive and select binary or text format. The Audit Trail records will be saved to a file using the default format of SystemAuditmm-dd-yyyy-hhhmmss.  The audit trail would then be viewable offline.

    After you have reviewed the archive copy of the Audit Trail, you could choose Archive and Remove.  It is very important to remember when considering this option you should remember it cannot be undone.

    Also the function requires two system administrator user accounts and passwords.

    I hope this is helpful.

    Dot

  • Thanks for the answer.

    We already tried an export of the audit trail in parts á one year. But this didn't work too. Somehow scans Empower all entries - and runs in the OOM error.

  • Hi

    We tried to archive Empower audit trail also in Empower 1.

    It prooved to be tricky.

    If you archive only first (to check for example, if the records are correct) and than you try to archive and remove it didn't work and created ORA errors. 

    We figured that during the first archive the proces creates the temporay archive table in Oracle schema.

    During archive and remove the proces entounters that first table and hangs creating Orcale erros.

    We went to Orcale databse, droped the tempoaray table altogether. Than we reparted the process of archive and remove and that worked. Requested chunk of adudit trail was removed from the database.

    Cheers

    Kate

Sign In or Register to comment.