Communication fail running GC 6890

Hi!I want to hear if anyone out there have experienced similar communication problems as we have running Agilent 6890 GC from Empower.The problem that we see is that from time to time - sometimes manytimes per day/week, sometimes it can work for month without failing - we see the system get stocked. Empower is waiting for an injection and the status on the GC state ready for injection but nothing happens.Some times the system freeze and you have to reboot the LAC/e to be able to stop the run and restart.We are using RS232 connection to equinox card for the communication.We have reach a point were we guess that it could be network related - but we have seen the problem at headquarter where the servers are placed and also in another site in DK.If the problem was network related I would expect the LAC/e just to buffer the run - not to get stocked. Does it works different with GC ?We have never seen the same problems with the 7890 GC running LAN - is the LAN connection more stable ?

Answers

  • When two or more Equinox serial-controlled systems (e.g., Agilent 6890 GCs) are connected to an Empower node with a multi-core processor, such as a Configuration 12 LAC/E, the systems may suffer intermittent communications problems.  In that case, the user may need to restart the WatersService, or reboot the LAC/E, in order to regain connection to the systems. This issue is documented as PCS 44289.

    Possible workaround:

    Within the BIOS, disable CPU multiplexing, so that the computer runs in single processor mode.

    Note: For Intel Desktop Boards, the BIOS option is generally called "Core Multiplexing Technology". If you have a non-Intel motherboard, you will need to check with your system vendor to determine if your system has a similar setting.

    This issue does not affect the Avocent Serial Hub driver.

  • Hi!

    We already implemented this change - but still we experience these communication problems from time to time and offen several in a small time frame and then it works fien for a period of time.

  • Hi Jeanette

    We feel this issue will requires more investigation than can be done in this forum.  Our Waters representative in your region has indicated that they will be in touch with you.  

    We will continue to work with you on this issue through our technical inquiry system.

    Once we have a resolution we will post it here for others to read.

    If you have any issues please contact me directly.

    Thank you

    Dot

  • We've seen some communication failures with serial controlled 6890's on one Config 12 LAC/E32 as well at one of our remote sites.   Is the suggested BIOS change a Waters recommended change?

  • Hello

    This is a suggestion not an overall recommendation.  We would like to assist.  Let us know more the details of your site’s configuration and the specifics of the behavior you are observing.

    Thank you

    Dot

  • I know this seems pretty simple, but I've seen similar connection problems with our GCs.  We're still on Empower1, which could be a bit of a problem in itself, but regularly rebooting the LAC/Es could solve your connectivity issues.  Of course maybe you're already doing this, in which case that suggestion doesn't help very much.  It seems to me to be similar to needing to restart your PC every so often or else you see strange things happening.

  • Hi Dot

    Did you get to the bottom of Jeanette's problem yet, we have just upgraded to Empower 2 and have started to get instrument failures with our HP6890plus.

    We have one GC connected to a Lac/e 13 box through the Avocent.

    At random points through the run and within an injection, the sample set aborts and an instrument failure is displayed in the message centre. The message centre does not identify or expand on the error at all. The GC does not show any errors.

    thanks

    Steve

  • We are now having exactly the same issues with Agilent GC 6890N with every run we perform and have been doing for the past month or so.  The Message center it states "instrument failure" but the instrument log does not show any such failure.  The injection stops part way through an injection but never at the same time or on the same injection. 

    The GC is connected via RS232 to an Avocent, to a LAC/E 32 running Empower2 build 2154 FR5 service pack G.  The system had been running fine for a few months then all of a sudden the runs would not complete.

    So far we have tried all of the following:

    • changing all of the cables
    • changing the LAC/E 32
    • rebooting the LAC/E
    • rebooting the instrument
    • changed the Avocent 8 port serial hub
    • disabled CPU multiplexing
    • matched the subnet masks of the instrument and company network connections
    • disconnected the LAC/E from the network
    • changed the mother board in the instrument

    So far none of these have resolved the issue.  However, if we connect the instrument to a ChemStation and perform the same run the instrument works fine.  If we connect the instrument to an old Empower2 standalone demo PC the run works fine.  This all started on the same day that we installed the 7890 driver v2.0 on the LAC/E and all client PCs.  We haven't had the chance to uninstall the 7890 driver but we have connected the 6890 to a LAC/E without the driver but the error still occurs.

    We can replicate the problem by disconnecting the serial cable from the back of the instrument and rapidly reconnecting it.  If the cable is left disconnected then the instrument completes the injection rather than stopping prematurely. This appears to imply that the fault is caused by a temporary breakdown in communication. We are actively investigating this and trying to narrow down the root cause.

    This is an urgent matter as this failure means that our instrument is currently unusable which is unacceptable.

  • Hello everyone,

    We have seen intermittent failures for Agilent instruments connected to bridged network cards. We are investigating the possibility of incompatibilities of the Avocent Serial Hub and Windows XP driver with multi core CPU, PCS 47492.

    For GC the CPU core multiplexing MUST be disabled in the LAC/E BIOS.

    If you are using a bridged network connection unbridge the connection and use a single network connection.

    Other suggestions that might be helpful in preventing failures are Power Management, Virus Scanning, and Firewalls.  It might be good to check the network connection properties

    1. Power Management tab settings to insure none of the three selections are checked.
    2. Advanced tab for the Firewall Advanced settings to insure the Instrument network connection excluded.

    I hope this is helpful.

    Dot

  • Hi Dot

    Thank you for your suggestions.

    We unbridged the network connections and installed an external network switch for the Avocent serial hub and other LAN instrument connections.  All systems are working properly again now!

    Thanks,

    Michelle

  • Hello,

    We are also experiencing intermittent communication issues with 6890 GCs and the Equinox serial cards.  We have disabled the dual core processor on the affected LAC/E devices but continue to get intermittent errors indicating,"HP6890 @ address 7, Inject Error - 122".

    What would be the suggested steps to resolve this issue?

    Thanks.

  • Hello

    “Inject Error - 122'  is usually interpreted as a hardware error. The user should check for impediments to the syringe mechanism, or possible problems with the syringe itself.

    Has this run successfully in the past?  Does the GC have an external ALS controller?

    It is possible that a hardware timing issue may have occurred to which an older GC is more likely to be susceptible. In those types of cases, we have previously suggested entering a small next injection delay - say 0.5 min to 1 min - in the GC sample sets for older GCs with external ALS controllers.

    Hopefully this information is helpful.

    Best regards

    Dot

  • Dot,

    Thank you for the prompt reply.

    We have incorporated the previously recommended next inject delays previously and still see this intermittent problem.  The system will run for several weeks without any issues then will quit mid-sample set with only the "Inject Error - 122" noted.  This system is an Agilent 6890 GC (G1530A) with an external controller (G1512A).

    Is this a problem with the Agilent hardware (autosampler, syringe, etc.) or is there an issue with how Empower is interpreting codes from the hardware?

  • Hello,

    This is not an issue of interpretating the codes by the Empower software.  The error is being passed straight through to the MessageCenter from the instrument.

    The inject error code indicates a true hardware error.  Further details on the meaning and its interpretation can be obtained from the instrument vendor. You may want to check with the vendor for suggestions to investigate or resolve this error.

    Has a Waters service representative been involved onsite to assist with this problem?  If not, I will be happy to contact the local manager to have someone set up an appointment.

    Best regards

    Dot

  • Hello,

    Most of the time,it could be related to instrument method where the cross configurations are used.Like Front inlet-Back detector;Back Inlet - Front Detector

    Regards

    Rathan

  • Hi!

    We seems to have solved the problems we had with the communication for GC 6890. problems was related to service on Win7 running at night - specially the Value shadow copier. This service exist on both XP and Win7 and in both cases they are set to manual. For Win7 the service started every night around 0:20 even it was manual. We disabled the service. next step to get rid of the problems has been to uninstall TrendMicro on all Win7 LACE - we also saw communication problems with the UPLC systems.

    Hope this can be of help to other with similar problems.

Sign In or Register to comment.